Missing Maximo 7.6 titlebar icons after upgrade from Maximo 7.1

We have experienced a weird bug in Maximo 7.6.0.3 where the title bar icons don’t show.  A fresh install works fine (I believe) but after an upgrade, the icons don’t show like so:

missingtitleicon

If you are new to Maximo 7.6, you should know that there should be “shortcut” icons in the title bar to the right of the MAXADMIN username.  But in this case there isn’t any.  Well technically, they are there, but they are hidden.  So to fix this, we need to modify the maximo.css to show them.

Open this file:

\IBM\SMP\maximo\applications\maximo\maximouiweb\webmodule\webclient\skins\skins-20160420-1515\tivoli13\css

and edit this CSS snippet right below this class of “.pwimg”, then rebuild and deploy:

	/* BEGIN titlebar */
	.titlebarlinks span.powerwhite img,
	.pwimg
	{
		display: inline !important;
		opacity:.7;
		filter:alpha(opacity=70);
	}

	.titlebarlinks span.powerwhite img:hover,
	.pwimg:hover
	{
		opacity:1;
		filter:alpha(opacity=100);
	}

It should now look like this:

showtitleicon

Note to IBM: If you are reading this, the reason it doesn’t work is because the tag is missing the “class=’pwimg'” attribute!!

Did You Know...

As Maximo Experts, we have developed several add-on products for Maximo that mobilize the work force, simplifies assignments, provides ad-hoc reporting capabilities and facilitates the seamless integration of Service Requests into Maximo.

Check out our products by clicking on the following links: EZMaxMobileEZPLanner and EZInsight.

Find Out More

Leave a Reply