Easily differentiate between MAXIMO production, test and development environments

I have seen this many times before where MAXIMO users are wanted to modify screens or text on the login page to show that the user is currently trying to connect to a production environment or a test instance of MAXIMO.  For example, you could modify the login page text with maxmessages.  Well, I have come up with a nice visual option for you to use.

I have modified the existing MAXIMO 7 background images and added some nicely designed text for the login page and the navigation bar with each application to show whether you are connecting to a production, test or development instance.  Here are some screens of what I have made:

[nggallery id=7]

You can download the images below for free.  To install these images, you can follow how I changed the BIRT report logo, or you just simply extract the ZIP file and copy the contents of the Maximo 7 folder into your MAXIMO installation directory.  (Example: <maximo install dir>/applications/maximo/maximouiweb/webmodule/webclient)  Copy the production, test, or development one based on whatever instance you are deploying to.  Don’t forget to rebuild and deploy EAR files.  Also, don’t forget to clear your browser cache in order for the new images to show on screen.

[wp_eStore_download_now_button_fancy_no_price id=2]

Did You Know...

As Maximo Experts, we have developed Maximo adds on products to make Maximo work assignment simple, reporting easy, and facilitating service requests seamless. Check out our additional products EZPlanner, EZInsight, and EZRequest.

Find Out More

9 thoughts on “Easily differentiate between MAXIMO production, test and development environments

  1. Hi
    I have tried the above with your images and it doesn’t seem to work on 7.1.1.6 on websphere.

    I have rebuilt the ear file, redeployed, restarted the server, cleared the internet browser cache and I still don’t see the changes.

    I extracted the maximouiweb file from the maximo.ear file and the files are in there.

    Do I have to clear something in the websphere directories?

  2. Hi

    I just tried something.

    I loaded the logon screen and then right click the mouse and did refresh and the MAXIMO Test appeared on the screen

    I also did the same once logged in.

    So what is the best way to clear the internet explorer cache. I went to tools > Internet options. Then browsing history > delete, selected everything and delete

Leave a Reply

Your email address will not be published. Required fields are marked *